不兼容问题补救:装有policycoreutils启用sandbox机制的中标麒麟6.5系统安装5.5-8112版本i2node,系统不停重启
发表于 2019-03-22
点击数 286

症状:


装有policycoreutils-sandbox-2.0.83-19.39.el6.x86_64,系统启用sandbox机制的中标麒麟6.5系统安装5.5-8112版本i2node安装时无报错,查看i2进程也正常,但在英方控制台添加节点后,机器不断重启,无法进入系统。

并且,进入单用户模式使用rpm -e卸载相应i2node安装包,也无法卸载成功,严重影响系统正常运行。

故障发生的系统环境信息如下:
1、系统类型
内核——2.6.32-431.56.1.el6.x86_64

发行版——Neokylin Linux Advance Server release 6.5(Beryllium)  ,也即中标麒麟6.5


2、安装节点后的系统日志/var/log/messages 有关sfs挂载的信息,如下图:

问题:


中标麒麟6.5系统安装5.5-8112版本i2node因版本,系统不停重启怎么办?


解决方案:

一、问题原因
5.5-8112  版本的 i2node 安装包不兼容装有policycoreutils-sandbox-2.0.83-19.39.el6.x86_64,系统启用sandbox机制的Neokylin linux 6.5内核为2.6.32-431.56.1el6.x86_64的系统

二、补救步骤
1、进入单用户模式
   
(1)系统重启过程中,启动界面读秒的时候按下任意键或Esc,跳转到操作系统的选择画面。上下键移动光标选择kernel …那一行,如下所示:

  

(2)键入“e”,进入命令行编辑,之后在出现的画面中提示符后输入“single”并回车,如下所示:

 (3)键入“b”,启动系统,即可进入单用户模式,如下所示:

2、单用户模式下,修改文件
       第一步成功进入单用户模式后,将 /etc/init.d/目录下的i2node文件更名为i2node_bak,从而达到开机不启动i2node服务的目的,修改完以后,重启系统,命令如下所示:
           mv /etc/init.d/i2node /etc/init.d/i2node_bak
           shutdown -r now

注意:
        若是6.0-12790版本的i2node,即使装有policycoreutils-sandbox-2.0.83-19.39.el6.x86_64,系统启用sandbox机制,也不存在兼容性问题。

相关文章
上一篇:
下一篇:

及时响应,快速服务,为您保驾续航

立即注册

销售咨询:400-0078-655
紧急报修:021-61735936
投诉热线:021-61679076
技术QQ群:532148075
欢迎加入!
请先完成图形验证

验  证  码:

隐私声明
当您在本网站进行合作伙伴注册登记,本网站将收集您的相关信息,并保存记录。本网站收集的个人信息包括但不限于:姓名、地址、公司、所在地区、电话号码以及电子邮件地址等。您主动提供的信息越多及越准确,我们就能够更好地为您提供有关服务。
咨询·购买